提示“No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)”错误的问题原因和解决方案

本文介绍使用第三方SSH客户端远程连接Linux实例时,提示“No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)”错误的问题原因和解决方案。

问题现象

当您使用第三方SSH客户端远程连接Linux系统的ECS实例时,输入了正确的账号和密码,但是还是出现类似以下错误信息。

Permission denied (publickey,gssapi-keyex,gssapi-with-mic)
sshd[10826]: Connection closed by XX.XX.XX.XX
No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)

putty fatal error

问题原因

使用密码或密钥登录都可能出现该问题,具体说明如下:

  • 使用密码登录出现该问题:可能是ECS实例内禁止用户使用密码方式连接,您可以将PasswordAuthentication参数值修改为yes以解决此问题。具体操作,请参见方案一:允许使用密码方式登录。

  • 使用密钥登录出现该问题:可能是ECS实例内禁止了密钥登录或SSH密钥对的公钥未加入对应用户.ssh/authorized_keys中,您可以检查/etc/ssh/sshd_config文件或重新上传公钥到authorized_keys文件中以解决此问题。具体操作,请参见方案二:复制公钥到authorized_keys文件。

方案一:允许使用密码方式登录

  1. 以VNC方式登录ECS实例。

    具体操作,请参见通过密码认证登录Linux实例。

  2. 查看/etc/ssh/sshd_config的参数PasswordAuthentication配置是否有误。

    sudo cat /etc/ssh/sshd_config

    如下图所示,PasswordAuthentication参数设置为no,表示禁止以密码方式登录,需要修改为yes。

    image

  3. 将PasswordAuthentication no修改为PasswordAuthentication yes。

    1. 打开SSH配置文件。

      sudo vim /etc/ssh/sshd_config
    2. 将PasswordAuthentication no修改为PasswordAuthentication yes。

      image

    3. 按Esc键,输入:wq保存修改。

  4. 执行如下命令,重启SSH服务。

    sudo systemctl restart sshd.service
  5. 重新远程连接Linux实例,如果可以正常连接,说明问题已解决。

方案二:复制公钥到authorized_keys文件

  1. 以VNC方式登录ECS实例。

    具体操作,请参见通过密码认证登录Linux实例。

  2. 查看/etc/ssh/sshd_config的参数PubkeyAuthentication配置是否有误。

    sudo cat /etc/ssh/sshd_config
    • 当PubkeyAuthentication参数为yes时,说明可能是SSH密钥对的公钥未加入对应用户.ssh/authorized_keys中,请执行步骤4。

    • 当PubkeyAuthentication参数为no,表示禁止以密钥方式登录,需要修改为yes。请执行步骤3。

      image

  3. 将PubkeyAuthentication no修改为PubkeyAuthentication yes。

    1. 打开SSH配置文件。

      sudo vim /etc/ssh/sshd_config
    2. 将PubkeyAuthentication no修改为PubkeyAuthentication yes。

      image

    3. 按Esc键,输入:wq保存修改。

    4. 执行如下命令,重启SSH服务。

      sudo systemctl restart sshd.service
  4. 复制公钥到authorized_keys文件。

    1. 执行如下命令,打开authorized_keys文件。

      sudo vim /home/user/.ssh/authorized_keys
      说明

      /home/user请替换成实际的用户。

    2. 按i键进入编辑模式。

    3. 将本地保存的公钥粘贴到authorized_keys文件中。

    4. 按Esc键,输入:wq退出编辑模式。

  5. 重新远程连接Linux实例,如果可以正常连接,说明问题已解决。

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/4182.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
阿里云服务器创建快照备份云盘数据
上一篇 2024年9月27日 下午10:48
Linux实例负载高问题排查和异常处理
下一篇 2024年9月28日 上午10:36

相关推荐

  • 关于linux中sed命令的示例代码分享教程-学派吧

    如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624 商祺云-阿里代理、景安代理、西部代理 简介 sed 是一种在线编辑器,它一次处理一行内容。处理时,把当前处理的行存储在临时缓冲区中,称为“模式空间”(pattern space),接着用sed命令处理缓冲区中的内容,处理完成后,把缓冲区的内容送往屏幕。接着处理下一行,这样不断重…

    服务器运维 2019年1月14日
    2.1K00
  • 学派吧-什么是Linux系统中nc命令?nc命令的用法教程

    这篇文章主要介绍了Linux系统中nc命令的基本用法,nc命令非常之强大,这里先简单介绍它用来作端口扫描以及文件传输等的基础使用。 功能说明:功能强大的网络工具<( ̄▽ ̄)>,在网络工具中有“瑞士军刀”美誉,其有Windows和Linux的版本。因为它短小精悍,功能实用,被设计为一个简单、可靠的网络工具,可通过TCP或UDP协议传输读写数据。同时…

    服务器运维 2019年1月1日
    2.9K00
  • 如何处理Ping ECS实例的IP地址间歇性丢包-linux教程

    本篇文章给大家带来的内容是关于如何处理Ping ECS实例的IP地址间歇性丢包,有一定的参考价值,有需要的朋友可以参考一下,希望对你有所帮助。 Ping ECS实例的IP地址间歇性丢包 问题描述 Ping ECS实例的IP地址间歇性丢包,ECS实例的网络一直处于不稳定状态 。 问题原因 系统中病毒。 解决方案 Ping外部存在丢包,但是延迟不大,排查不是带宽…

    服务器运维 2018年11月21日
    2.9K00
  • 关于Win2008R2服务器配置VPN服务器的图文教程方法-windows教程-学派吧

    这篇文章主要介绍了Win2008 r2服务器配置VPN服务器教程(图文详解),需要的朋友可以参考下 系统环境:WindowsServer2008R2Enterprise(完全安装) 1、配置准备工作1.1、点击“开始”右边的“服务器管理器”1.2、在“服务器管理器”里点击“角色”1.3、在“角色”上点击右键选译“添加角色”,点击“下一步”1.4、在“角色”里…

    服务器运维 2018年12月2日
    3.9K00
  • 介绍beego、nginx性能测试实例教程分享-学派吧

    如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624商祺云-阿里代理、景安代理、西部代理 测试工具:ab(apacheBench) 硬件环境: Intel xeon cpu E5-2682 v4 2.50GHz 4 core 8GBytes 内存 软件环境: ubuntu16 nginx 静态文件 3Kbytes 26000次响应…

    服务器运维 2019年1月15日
    2.9K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部