Linux服务器安全防御设置教程

预防黑客和服务器安全是系统管理服务的主要任务。下面是一些Linux服务器的基本安全提示。

Linux

1、强密码策略

设置强密码是保护服务器安全的第一步。不要使用普通名称作为密码,如姓名、出生日期、手机号码等。密码应为字母数字,并带有大小写字母。

您可以在Linux机器上使用密码老化策略强制用户定期更改那里的密码。

例子:

获取密码老化信息

#chage -l username

更改密码老化信息

# chage -m 7 -M 60 -W 15 username
-m: Minimum number of days between password change
-M: Maximum number of days between password change
-W: Number of days of warning before password expires

禁用密码老化(不建议在生产服务器上使用)

# chage -M 99999 username

2、禁用root登录

root帐户拥有无限的特权,所以请在服务器上保持禁用root帐户。同时确保没有其他用户使用下面的命令,uid或gid 0,只有root用户行应该同时列出这两个命令。

# awk -F: '($3 == "0") {print}' /etc/passwd
# awk -F: '($4 == "0") {print}' /etc/passwd

要执行root级别命令,可以在服务器上配置sudo权限。

3、保持系统最新

始终使用最新的软件补丁或更新来保持系统最新状态。您可以使用Linux实用程序(yum,apt-get等)来更新最新的系统。确保定期更新系统。

例如:

# yum update
or
# apt-get update && apt-get upgrade

还可以使用yum-updatesd服务在发现任何新更新时启用电子邮件通知。

4、使用安全协议进行远程访问

从远程或传输数据访问服务器都要使用安全协议。所有的安全协议都是加密数据传输。

不使用:

> rcp
> telnet
> ftp

使用

> ssh
> scp
> sftp(基于SSL的FTP)

5、禁用不需要的服务

系统中有许多服务在后台运行。找出并禁用所有不需要的服务。

查找系统启动时将启动的所有服务

# chkconfig --list | grep ':on'

停止服务器上不需要的所有服务。

# service service-name stop

禁用服务以在系统引导时启动

# chkconfig service-name off

本篇文章到这里就已经全部结束了,

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/3367.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
如何调试shell脚本教程分享
上一篇 2019年3月23日 下午11:20
bash scp:未找到命令的解决教程分享
下一篇 2019年3月23日 下午11:21

相关推荐

  • 腾讯云轻量服务器如何修改密码和重装系统

    腾讯云轻量应用服务器怎么重置密码呢 有时我们需要远程登录轻量应用服务器的时候,需要输入用户名和密码。而轻量应用服务器默认是没有设置密码的。这就需要先重置一下密码。 打开腾讯云轻量应用服务器控制台,点击“更多”,再选择“管理”,如图 如何重新安装系统呢 。看下图

    2022年3月24日
    4.3K00
  • linux/centos中chmod命令怎么用?(详解)

    在linux中chmod命令允许用户更改文件和文件夹的访问权限;与其他命令一样,chmod命令可以通过命令行或脚本文件执行来执行。 chmod命令语法 这是使用chmod命令时的正确语法: chmod [options] mode [,mode] file1 [file2 …] 以下是chmod使用的一些常用选项: ● -f, – silen…

    服务器运维 2019年5月7日
    7.3K10
  • php-fpm启动参数及详解

    约定几个目录/usr/local/php/sbin/php-fpm/usr/local/php/etc/php-fpm.conf/usr/local/php/etc/php.ini一,php-fpm的启动参数 #测试php-fpm配置 /usr/local/php/sbin/php-fpm -t /usr/local/php/sbin/php-fpm -c …

    服务器运维 2018年8月16日
    3.1K00
  • 腾讯云服务器linux系统MBR 分区云硬盘扩容至大于2TiB

    当您的云硬盘在已有 MBR 分区并已创建文件系统的情况下,扩容至大于 2TiB,此时 MBR 分区下的文件系统已无法扩容至大于 2TiB,请参见本文将 MBR 分区形式转换为 GPT 分区形式 注意事项 请谨慎操作,误操作可能会导致数据丢失或异常。请给对应云硬盘创建快照,完成数据备份。详情请参见 创建快照。如出现误操作导致数据丢失,则可回滚快照进行数据恢复。…

    2026年1月13日
    47200
  • 宝塔数据库报错:ERROR! MySQL server PID file could not be found!

    问题描述 客户因给服务器清理日志、不清楚具体操作了什么 ,清理完成以后,数据库启动不了。报错如下: [root@VM-0-5-centos ~]# /etc/init.d/mysqld restartERROR! MySQL server PID file could not be found!Starting MySQL…. ERROR! Th…

    2021年7月21日
    3.7K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部