腾讯云对象存储(cos)挂载到centos下-射到本地磁盘目录教程分享

本文目标

本文旨在利用腾讯云提供的COSFS工具,将腾讯云的对象存储映射到云服务器的本地磁盘目录上。

推荐腾讯云代理商

代理型关联:

https://partner.cloud.tencent.com/invitation/5411729459845f8015bc1/100010025276?inviteType=2

前提条件

假设我们已经新建了腾讯云的对象存储(COS),信息如下:

640.jpg
存储桶名称(bucket_name):kenny-hexo 替换成你自己的
存储桶APPID(bucket_appid):1256238228 替换成你自己的
存储桶访问域名(bucket_region):https://kenny-hexo-1256238228.cos.ap-beijing.myqcloud.com 替换成你自己的
API秘钥id(SecretId):AKIDXXXXXXXXXXXXXXXXXXXXXXBM951 替换成你自己的
API秘钥key(SecretKey):8IUgXXXXXXXXXXXXXXXXXXXXXweB 替换成你自己的
COSFS工具

功能说明

COSFS 工具支持将 COS 存储桶挂载到本地,像使用本地文件系统一样直接操作腾讯云对象存储。COSFS 的主要功能包括:

支持 POSIX 文件系统的大部分功能,如:文件读写、目录操作、链接操作、权限管理、uid/gid 管理等功能;
大文件传输功能;
MD5 数据校验功能。

使用环境

CentOS 7 64bit

CentOS 系统下安装环境依赖包

sudo yum install automake gcc-c++ git libcurl-devel libxml2-devel fuse-devel make openssl-devel

下载并编译安装工具

git clone https://github.com/tencentyun/cosfs /usr/cosfs  #获取源码
cd /usr/cosfs
./autogen.sh
./configure
make
sudo make install
cosfs --version  #查看 cosfs 版本号    #这个最好看一下,之前我就下错版本了,导致后面挂载时语法有错误,耗了很长时间

按照之前申请的API创建配置文件

echo bucketname:SecretId:SecretKey /etc/passwd-cosfs
chmod 640 /etc/passwd-cosfs

实例:

echo sqy-13007899:AKIDcBWcT4MXOI8j5BOcxSnwCIBRItlefQ:LRIvKgoiNltmSxTArLccN2TmvfEdrq> /etc/passwd-cosfs
chmod 640 /etc/passwd-cosfs

创建目录并挂载

1 mkdir -p /cos
2  
3 cosfs   -ourl= -odbglevel=info    #这是版本1.0.5以上的方法
v1.0.5 之前版本 COSFS 的挂载命令如下:
 
cosfs :  -ourl=

其中:

为本地挂载目录(如 /mnt)。
为存储桶对应的访问域名,形式为 http://cos..myqcloud.com(适用于XML API,请勿在该参数中携带存储桶名称),其中 为地域简称, 如: ap-guangzhou 、 eu-frankfurt 等。更多地域信息,请查阅 可用地域。
-odbglevel 指定日志级别。

示例:

cosfs sqy-1300789944 /cos -ourl=http://cos.ap-shanghai.myqcloud.com -odbglevel=info

下面可以看到挂载上去了,256T的空间
到这里就是挂载成功了,不过因为腾讯就给了我50G的空间,不太清楚存储超过50G后会怎么样,会存储不上还是会自动收费?再慢慢摸索吧

另外这个在内网中是不限流量的,也就是说你可以将你在腾讯云服务器上的数据备份到这里是不收费的,外网进来的有10G免流,如果只是备份个网站数据,一般都够用了

卸载存储桶

umount -l /cos

注意

如果无法做到开机自动挂载 就需要安装下面的依赖

sudo yum install automake gcc-c++ git libcurl-devel libxml2-devel fuse-devel make openssl-devel fuse

编辑vim 进行开机自动挂载

cosfs#sqy-1300744 /cos fuse _netdev,url=http://cos.ap-shanai.myqcloud.com,dbglevel=info

————————————————
版权声明:本文为学派吧的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://www.xp8.net/server/unix/3814.html

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/3814.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
centos(linux)下如何备份数据库教程说明-已经测试过
上一篇 2019年11月22日 下午1:47
【腾讯云】云产品采购季,助力行业复工。1核2G云服务器,首年优惠99元-腾讯云代理
下一篇 2020年2月14日 下午9:03

相关推荐

  • 学派吧-Linux下安装配置MySQL的教程-linux教程

    mysql最流行的关系型数据库之一,目前隶属于oracle公司,因体积小、速度快、总体拥有成本低,开放源代码这一特点,所以是我们日常开发的首选。下面我们来看看如何在Linux下安装配置MySQL 系统:Ubuntu 16.04LTS 1\官网下载mysql-5.7.18-linux-glibc2.5-x86_64.tar.gz 2\建立工作组: $su #g…

    服务器运维 2018年12月19日
    2.8K00
  • Linux7如何设置静态IP的方法教程-学派吧

    这篇文章主要介绍了Centos Linux7设置静态IP的实例的相关资料,需要的朋友可以参考下 如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624商祺云-阿里代理、景安代理、西部代理 Centos Linux7设置静态IP的实例 ## 先进入配置文件的放置位置: cd /etc/sysconfig/network-scripts…

    服务器运维 2019年1月4日
    2.3K00
  • 关于腾讯云服务器上海、中国香港地区访问宝塔面板异常的解决方法

    近期上海机房连接广东电信、或我司广东其他节点存在异常。大多表现在用户访问宝塔面板时加载软件商店慢、打不开或绑定不了账户;或登录面板首页直接报错【面板运行时发生错误: 解析软件列表发生错误,已尝试自动修复,请刷新页面重试!】云服务器上海地区的用户,可以尝试执行下面的命令,指定节点解决此问题 #优先选择这2条命令执行 sed -i “/bt.cn/d” /etc…

    2022年3月14日
    4.0K00
  • Linux中如何配置ftp服务器教程分享

    如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624 商祺云-阿里代理、景安代理、西部代理 1. 先用rpm -qa| grep vsftpd命令检查是否已经安装,如果ftp没有安装,使用yum -y install vsftpd 安装,(ubuntu 下使用apt-get install vsftpd) 2. service v…

    服务器运维 2019年1月17日
    3.0K00
  • 宝塔输入bt提示/usr/bin/bt: line 129: syntax error: unexpected end of file解决办法

    最近有遇到过安装完面板时候,输入bt 报 /usr/bin/bt: line 129: syntax error: unexpected end of file 的错误出现这个问题可能原因:1、网络波动导致无法将宝塔文件写入到/etc/init.d/bt 这个系统文件2、源文件缺失下面是解决办法: 1、mv /etc/init.d/bt /tmp/bt_ba…

    2019年4月21日
    4.8K00

发表回复

登录后才能评论

评论列表(1条)

联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部