如何在Apache中创建和安装自签名证书教程-学派吧

SSL对于用户和Web服务器之间的安全通信很有用。证书在公共线路上传输时对数据进行加密,这样它就不会受到黑客的攻击。自签名证书是免费使用的,但不在生产环境中使用,例如使用信用卡、Paypal信息的机密数据。本篇文章将介绍关于在Linux系统上的Apache服务器中创建和安装自签名证书。

如何在Apache中创建和安装自签名证书教程-学派吧

步骤1:安装mod_ssl包

要设置SSL证书,请确保在系统上安装了mod_ssl。如果尚未安装,需要使用以下命令进行安装。另外,安装openssl包来创建证书。

$ sudo apt-get install openssl          # Debian based systems 
$ sudo yum install mod_ssl openssl      # Redhat / CentOS systems 
$ sudo dnf install mod_ssl openssl      # Fedora 22+ systems

步骤2:创建自签名证书

安装mod_ssl和openssl后,使用以下命令为你的域创建一个自签名证书。

$ sudo mkdir -p /etc/pki/tls/certs
$ sudo cd /etc/pki/tls/certs

现在创建SSL证书

$ sudo openssl req -x509 -nodes -newkey rsa:2048 -keyout example.com.key -out example.com.crt

输出

Generating a 2048 bit RSA private key
....................................+++
...................................+++
writing new private key to 'example.com.key'
-----
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [XX]: IN
State or Province Name (full name) []: Delhi
Locality Name (eg, city) [Default City]: Delhi
Organization Name (eg, company) [Default Company Ltd]: TecAdmin
Organizational Unit Name (eg, section) []: blog
Common Name (eg, your name or your server's hostname) []: www.example.com
Email Address []: admin@example.com

上面的命令将在当前目录中创建一个ssl密钥文件example.com.key和一个证书文件example.com.crt。

步骤3:在Apache中安装自签名证书

现在拥有了自签名SSL证书和密钥文件。接下来编辑Apache SSL配置文件并按照以下指令进行编辑/更新。

Apache虚拟主机配置:

<VirtualHost _default_:443>
    ServerAdmin admin@example.com
    ServerName www.example.com
    ServerAlias example.com

    DocumentRoot /var/www/html

    SSLEngine on
    SSLCertificateFile /etc/pki/tls/certs/example.com.crt
    SSLCertificateKeyFile /etc/pki/tls/certs/example.com.key
</VirtualHost>

步骤4:重启Apache

如果上面的命令没有显示任何错误,请重新启动Apache服务。

$ sudo systemctl restart apache2       # Debian based systems   
$ sudo systemctl restart httpd         # Redhat based systems

步骤5:使用https测试网站

最后,使用https在你的Web浏览器中打开你的站点。它需要打开端口443才能使用HTTPS访问站点。

 https://www.example.com

当我们使用自签名证书时,你将在浏览器中收到一条警告消息,忽略此消息就可以了。

 

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/3634.html

(0)
打赏 微信扫一扫 微信扫一扫
linux/centos中删除文件命令是什么:警告请勿乱用-学派吧
上一篇 2019年5月7日 下午9:55
Linux 虚拟网络设备 veth-pair 详解很牛逼的资料分享
下一篇 2019年5月7日 下午9:55

相关推荐

  • vi /etc/fstab开机挂载及使用教程分享-学派吧

    某些时候当Linux系统下划分了新的分区后,需要将这些分区设置为开机自动挂载,否则,Linux是无法使用新建的分区的。 /etc/fstab 文件负责配置Linux开机时自动挂载的分区。 Windows的文件结构是多个并列的树状结构,最顶部的是不同的磁盘(分区),如:C,D,E,F等。Linux的文件结构是单个的树状结构。最顶部的为根目录,即/。在根目录下,…

    服务器运维 2019年4月20日
    4.5K00
  • 学派吧-Linux/centos通过端口转发来实现访问内网服务的图文教程-linux教程

    可以通过端口映射的方式,来通过具有公网的云服务器 ECS 访问用户名下其它未购买公网带宽的内网 ECS 上的服务。端口映射的方案有很多,比如 Linux 下的 SSH Tunnel、rinetd,Windows 下的 portmap 等,本文简要介绍 rinetd,和 ssh tunnel 的配置方法。 说明:本文相关配置和说明仅用于示例和操作指引,阿里云不…

    服务器运维 2018年12月12日
    3.6K00
  • 最新如何在macOS上安装Homebrew的图文教程

    Homebrew是最受欢迎的macOS系统包管理工具,使用brew命令行实用程序,可以轻松地在Mac上添加新软件包,但首先必须安装它。本篇文章将介绍如何使用简单命令在系统上安装Homebrew。 如何安装Homebrew? 在系统上启动终端(/applications/utilities/terminal)应用程序,然后在其上运行以下命令。 $ ruby -…

    服务器运维 2019年5月7日
    3.6K00
  • win2008 R2中安装MySQL出现ODBC连接器安装错误的解决教程-win教程-学派吧

    这篇文章主要介绍了win2008 R2中php.cn/php/php-tp-inst安装MySQL出现ODBC连接器安装错误,需要的朋友可以参考下 我今天打算在Windows server 2008 R2中安装MySQL,可是总是发现ODBC连接器安装错误,无论我采用MySQL的整体安装包,还是单独的ODBC连接器安装文件!! 最后上网搜索了很久,终于解决了…

    服务器运维 2018年12月2日
    3.3K00
  • 如何处理Ping ECS实例的IP地址间歇性丢包-linux教程

    本篇文章给大家带来的内容是关于如何处理Ping ECS实例的IP地址间歇性丢包,有一定的参考价值,有需要的朋友可以参考一下,希望对你有所帮助。 Ping ECS实例的IP地址间歇性丢包 问题描述 Ping ECS实例的IP地址间歇性丢包,ECS实例的网络一直处于不稳定状态 。 问题原因 系统中病毒。 解决方案 Ping外部存在丢包,但是延迟不大,排查不是带宽…

    服务器运维 2018年11月21日
    2.9K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部