inode索引节点用满报错mkdir: cannot create directory `xxx’: No space left on device

小编今天维护一台服务器、数据库无法启动、也无法建立文件目录等操作。都提示No space left on device

后来仔细查看洗了 是因为inode满了。那就赶紧想办法清理下了。

命令:df -i

其中/dev/mapper/vg_have-lv_root 884208 884208 0 100% /索引节点 (inode)满了

inode索引节点用满报错mkdir: cannot create directory `xxx’: No space left on device

已经找出问题所在,那么下面开始处理这个问题。

读出/目录下文件最多的目录:

for i in /*; do echo $i; find $i |wc -l|sort -nr; done

/var /www目录文件数高达10W以上,其中/var目录80W,/www为数据盘

再次读出/var目录下文件最多的目录:

for i in /var/*; do echo $i; find $i |wc -l|sort -nr; done

以此类推的往下找,最后在clientmqueue目录中文件数最多,切换到clientmqueue下使用rm -rf * 结果返回-bash: /bin/rm: Argument list too long
换用命令find . -print|xargs rm 过了一段时间终于删除了所有文件 df -i 下图可以看到文件数在减少
inode索引节点用满报错mkdir: cannot create directory `xxx’: No space left on device
不过这种方法只是治标不治本的方法。

为什么var/spool/clientmqueue会产生大量的文件呢,查资料是因为cron执行时会将相关结果以mail方式发送到执行用户的帐号,可是当sendmail 沒有启动 那么所有信件就会暂存在这个目录中,此时就会出现这种情况。
注意:一般使用宝塔的用户,使用网站统计会出现这个问题。
欢迎关注学派
有偿代维 故障排查.服务器租用 面板安装等服务 QQ:690624

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/3521.html

(0)
打赏 微信扫一扫 微信扫一扫
宝塔linux面板mysql报错ERROR! Failed to stop running server, so refusing to try to start.解决方法
上一篇 2019年4月15日 下午11:12
下一篇 2019年4月20日 下午10:29

相关推荐

  • linux安装安全狗

    [v_notice]现在给很多用户安装了宝塔、但是怕不有攻击、所以安装个安全狗[/v_notice]使用wget方式下载发布包:wget http://down.safedog.cn/safedog_linux64.tar.gz 安装网站安全狗 在root 帐户下执行以下命令: tar xzvf safedog_linux64.tar.gz(在这里一定要看解…

    服务器运维 2018年8月13日
    4.7K00
  • 学派网分享Linux命令快捷方式大全资料-linux教程

    如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624商祺云-阿里代理、景安代理、西部代理 命令行编辑的辅助操作: Tab健:自动补齐 Ctrl +U :清空至首行 Ctrl +K: 清空至尾行 Ctrl +L:(或者clear) 清屏 Ctrl +C: 取消执行命令 获取帮助命令: 内部命令help 例如:help cd 大多数外…

    服务器运维 2019年1月15日
    2.7K00
  • bt宝塔专业版切换免费版降级恢复

    前言 这几天看到群里很多朋友反馈。购买了一个月专业版,想恢复到免费版,不知道如何处理。今天小编把教程整理下发布出来。 操作 切换至免费版: wget -O update.sh http://download.bt.cn/install/update.sh && bash update.sh free 切换至专业版: wget -O update.sh htt…

    服务器运维 2018年9月21日
    6.1K00
  • 什么是Linux使用者控制计划任务Crontab命令及详解-linux教程

    linux 系统则是由 cron (crond) 这个系统服务来控制的。Linux 系统上面原本就有非常多的计划性工作,因此这个系统服务是默认启动的。另 外, 由于使用者自己也可以设置计划任务,所以, Linux 系统也提供了使用者控制计划任务的命令 :crontab 命令。 一、crond简介 crond 是linux下用来周期性的执行某种任务或等待处理某…

    服务器运维 2019年1月1日
    3.3K00
  • 腾讯云代理使用标准登录方式登录 Linux 实例-新云

    操作场景 以下视频介绍了如何登录 Linux 实例: WebShell 为腾讯云推荐的登录方式。无论您的本地系统为 Windows,Linux 或者 Mac OS,只要实例购买了公网 IP,都可以通过 WebShell 登录。 本文介绍如何使用标准登录方式(WebShell)登录 Linux 实例。WebShell 优点如下: 支持快捷键复制粘贴。 支持鼠标…

    2020年9月23日
    2.5K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部