linux共享上网设置的实例教程分析

这篇文章主要介绍了linux共享上网设置实例详解的相关资料,需要的朋友可以参考下

如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624
商祺云-阿里代理、景安代理、西部代理

linux共享上网设置

1、打开内核ip转发

vi /etc/sysctl.conf 
 
net.ipv4.ip_forward = 1

执行sysctrl -p生效

2、如果主机未启用防火墙,那么如下设置iptables

[root@Web-Lnmp02 ~]# iptables -F
[root@Web-Lnmp02 ~]# iptables -P INPUT ACCEPT
[root@Web-Lnmp02 ~]# iptables -P FORWARD ACCEPT 
[root@Web-Lnmp02 ~]# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
或者
           iptables -t nat -A POSTROUTING -s ip -o eth0 -j MASQUERADE  
 
//指定某ip或ip段可以转发
iptables -t nat -A POSTROUTING -s 192.168.0.170 -o enp1s0 -j MASQUERADE
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o enp1s0 -j MASQUERADE
 
 
[root@Web-Lnmp02 ~]# /etc/init.d/iptables save
[root@Web-Lnmp02 ~]# /etc/init.d/iptables restart
说明:
 iptables -F #清除原有的filter有中的规则 
 iptables -t nat -F #清除原有的nat表中的规则
 iptables -P FORWARD ACCEPT #缺省允许IP转发

如果主机上启用了防火墙,需加上下面两句:

Code:

iptables -A FORWARD -s 192.168.122.0/24 -o eth0 -j ACCEPT 
iptables -A FORWARD -d 192.168.122.0/24 -m state --state ESTABLISHED,RELATED -i eth0 -j ACCEPT

以上就是linux共享上网设置的实例分析的详细内容,更多请关注学派吧其它相关文章!

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/2929.html

(0)
打赏 微信扫一扫 微信扫一扫
阿里云服务器数据库等产品促销活动整理链接礼包分享
上一篇 2019年1月2日 下午10:43
下一篇 2019年1月4日 下午8:42

相关推荐

  • Ansible自动部署nginx+keepalived高可用负载均衡教程及方法

    今天学派吧给大家分享一篇关于负载均衡的教程 1. 部署前准备工作 2. Ansible主机与远程主机秘钥认证 3. 安装配置Ansible 4. 编写roles,实现web的部署 5. 编写roles角色部署nginx+keepalived 6. 编写roles角色 7. 其他问题 本篇文章记录通过Ansible自动化部署nginx的负载均衡高可用,前端代理…

    2018年10月11日
    2.6K00
  • HTTP 错误 500.0 – Internal Server Error

    错误出现情形:此错误一般出现在网站搬家到新网站空间报错。 错误原因:web.config文件中定义的php版本路径出错。 原有空间php文件路径: 新空间文件路径: 修改后就能正常使用了

    2018年7月17日
    4.9K00
  • nginx 和 frp共用80端口教程

    之前用frp做内网穿透,把内网的服务器开放到外网。 如果是http服务的话,80端口的做法是使用二级域名xxx做个A记录指一台没有nginx 之类的服务器IP,然后用浏览器打开xxx.example.com就打开了。其他端口是在frpc.ini里指定的,就加个端口号如xxx.example.com:1234就打开了,这种情况用于外网服务器已经有nginx在运…

    服务器运维 2018年10月16日
    5.2K00
  • bash scp:未找到命令的解决教程分享

    scp命令用于通过ssh在两台服务器之间传输文件。大多数scp用户在系统中已经可以使用scp命令,但它仍然显示“bash:scp:command not found”。因此注意,scp命令必须在本地和远程系统上都可用才可以避免这个问题。 安装SCP命令包 scp命令来自Red Hat系统上的openssh-clients软件包,openssh-client软…

    2019年3月23日
    7.0K00
  • Linux-centos下nginx日志每天定时切割教程

    教程目的: 使用Linux系统自带的命令logrotate对Nginx日志进行切割。 Nginx安装目录:/usr/local/nginx/ Nginx日志目录:/usr/local/nginx/logs/、/usr/local/nginx/logs/nginx_logs/ 1、添加nginx日志切割脚本 cd  /etc/logrotate.d  #进入目…

    服务器运维 2018年10月17日
    2.6K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部