在MySQL中如何使用LOAD_FILE()函数?(代码示例)-mysql教程-学派吧

在MySQL中,LOAD_FILE()函数读取一个文件并将其内容作为字符串返回。

语法

LOAD_FILE(file_name)

其中file_name是文件的完整路径。

下面是我从一个文件中选择内容的示例:

SELECT LOAD_FILE('/data/test.txt') AS Result;

结果:

+------------------------------------------+
| Result                                   |
+------------------------------------------+
| This text is all that the file contains! |
+------------------------------------------+

一个数据库的例子

下面是一个将文件内容插入数据库时查询的示例:

INSERT INTO MyTable (FileId, UserId, MyBlobColumn) 
VALUES (1, 20, LOAD_FILE('/data/test.txt'));

在本例中,列MyBlobColumn有一个BLOB数据类型(允许它存储二进制数据)。

现在它在数据库中,我们可以选择它:

SELECT MyBlobColumn
  FROM MyTable
  WHERE UserId = 20;

结果:

+------------------------------------------+
| MyBlobColumn                             |
+------------------------------------------+
| This text is all that the file contains! |
+------------------------------------------+

如果文件不存在,返回NULL:

SELECT LOAD_FILE('/data/oops.txt') AS Result;

结果:

+--------+
| Result |
+--------+
| NULL   |
+--------+

如果不满足以下条件之一,都有可能返回NUll:

1.文件必须位于服务器主机上。

2.你必须具有该FILE权限才能读取该文件。拥有该FILE权限的用户可以读取服务器主机上的任何文件,该文件是world-readable的或MySQL服务器可读的。

3.文件必须是所有人都可读的,并且它的大小小于max_allowed_packet字节。

你可以这样检查:

SHOW VARIABLES LIKE 'max_allowed_packet';

结果:

+--------------------+----------+
| Variable_name      | Value    |
+--------------------+----------+
| max_allowed_packet | 67108864 |
+--------------------+----------+

如果secure_file_priv系统变量被设置为非空目录名,则要加载的文件必须位于该目录中。

你可以这样检查:

SHOW VARIABLES LIKE 'secure_file_priv';

结果:

+------------------+--------+
| Variable_name    | Value  |
+------------------+--------+
| secure_file_priv | /data/ |
+------------------+--------+

在本例中,我只能从/data/目录中读取文件。

相关推荐:《MySQL教程》

本篇文章就是关于LOAD_FILE()函数在MySQL中的使用介绍,希望对需要的朋友有所帮助!

以上就是在MySQL中如何使用LOAD_FILE()函数?(代码示例)的详细内容,更多请关注php中文网其它相关文章!

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/data/3452.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
MySQL数据库优化的介绍(图文)-mysql教程-学派吧
上一篇 2019年4月9日 下午8:57
下一篇 2019年4月9日 下午8:57

相关推荐

  • mysql数据库无法启动-进行数据备份搬迁的教程

    今天看到一个案例:数据库服务无法启动,也导致了不能备份数据库、所以只能使用了笨方法、直接打包DATA目录 我们的服务器是宝塔环境、  直接备份 /www/server/data 这个目录备份 下载下来  在新的服务器上安装好环境、把data压缩包上传上去、进行解压覆盖、注意的是 版本最好一样。 重启一下数据库、 [root@VM_166_22_centos …

    2019年4月27日
    5.6K00
  • 在MySQL 5.7上使用group by语句出现1055错误问题-mysql教程-

    本文的主要内容是讲述在MySQL 5.7上使用group by语句出现1055错误的问题分析以及解决办法,有需要的朋友可以看一下。 1. 在5.7版本以上mysql中使用group by语句进行分组时, 如果select的字段 , 不是完全对应的group by后面的字段 , 有其他字段 , 那么就会报这个错误 ERROR 1055 (42000): Exp…

    数据库运维 2019年4月24日
    3.9K00
  • SqlServer2008数据库占用内存一直增长

    前言 最近碰到一个sqlserver数据库占用内存一直增长。直接到挂机 解决方案1 入Sql server 企业管理器(管理数据库和表的,这个都不知道就不用往下看了),在数据库服务器名称上点击【右键】,选择【属性】,然后,找到【内存】选项,在右边的【使用SWE分配内存】左边把对勾打上。在最大服务器内存(MB)上填入适当的大小(具体填多大,肯定不能超过计算机的…

    数据库运维 2018年9月14日
    4.0K00
  • SQL Server数学函数的简单总结-mysql教程-学派吧

    在前面的文章中,我们给大家介绍《mysql数学函数的简单总结》,下面我们继续为大家简单整理了SQL Server数学函数。 Transact-SQL包含许多可以与SQL Server一起使用的数学函数。 可以在SQL Server 2012及更高版本中使用以下标量函数。这些函数中的大多数接受一个或多个参数,并将根据提供的参数返回一个数值。 ABS() 返回指…

    2019年4月9日
    2.9K00
  • Linux系统MySQL备份的导入导出的具体操作教程-学派吧

    问题描述 如何对 ECS Linux 系统中的 MySQL 进行备份的导入和导出。 处理办法 MySQL 备份的导出 MySQL 备份的导入 MySQL 备份的导出 注意: 如果您使用的是帮助中心的一键环境配置,那么 MySQL 的安装目录是 /alidata/server/mysql。 如果您将 MySQL 安装到其他目录,您需要输入您 MySQL 完整的…

    数据库运维 2019年1月1日
    2.5K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部