Navicat for Oracle工具连接oracle的方法教程

本篇文章给大家带来的内容是关于Navicat for Oracle工具连接oracle的方法步骤(图文),有一定的参考价值,有需要的朋友可以参考一下,希望对你有所帮助。

这是一款oracle的客户端的图形化管理和开发工具,对于许多的数据库都有支持。之前用过 Navicat for sqlserver,感觉很好用,所以下载了Oracle版的用。

上网查看了一下这个工具可以用于任何版本 8i 或以上的 Oracle 数据库服务器,并支持大部份 Oracle 最新版本的功能,包括目录、表空间、同义词、实体化视图、触发器、序列、类型等。下边的这张图是oracle版的,MySQL和Sql Server版基本一样。

Navicat for Oracle工具连接oracle的方法教程

界面简洁,无冗余,对于日常的数据操作基本可以满足。以下是对其的安装和配置,这里重点讲配置

一、Navicat for Oracle的安装:

软件的安装就不多说了,基本都是一直下一步。网上有那种免安装破解版的,拿来可以直接用。

二、Navicat for Oracle的配置

1、启动该工具,出现开始界面,单击 “文件”—-“新建连接”选项,进行连接数据库。

Navicat for Oracle工具连接oracle的方法教程

Navicat for Oracle工具连接oracle的方法教程

2、在“新建连接”对话框中,输入任意的连接名,选择默认的连接类型,输入oracle数据库所在的服务器地址,连接本地的oracle可输入“localhost”,oracle的默认端口号是“1521”,输入数据库的SID或者是该数据库所对应的服务名,输入用户名和密码,这里我使用的是“test”,单击“连接测试”按钮,进行测试,连接成功,如图所示:

Navicat for Oracle工具连接oracle的方法教程

3、初次连接,在选择开始测试的时候,往往会出现错误:

“ORA-12737: Instant Client Light: unsupported server character set CHS16GBK”,这个错误是很典型的,是由于服务器的编码不支持造成的,但是如果我改变了服务器的字符集编码,这是不现实的,所以上网找了解决的方案,最后知道了只要去oracle官网下载一个最新版的OCI的文件,将原先的OCI的文件的覆盖即可解决下。该文件在博客的末尾已经提供了。

下面是文件替换的过程,下载的文件是解压,找到其中的4个文件:oci.dll,orannzsbb11.dll,oraocci11.dll,oraociei11.dll(这个文件最重要)。

选则“工具”菜单下的“选项”命令,如图所示打开选项的界面。

Navicat for Oracle工具连接oracle的方法教程

4、在“其它”的下边选择OCI,在右边的第一个的文件浏览的地方,选择oci.dll的位置,我的默认的位置是“F:\Program Files\Navicat_for_Oracle(www.greenxf.com)\Navicat for Oracle\instantclient_10_2\oci.dll”,把从压缩文件中取出的四个文件放到该目录下,其他的可备份,如下图所示下:

Navicat for Oracle工具连接oracle的方法教程

Navicat for Oracle工具连接oracle的方法教程

5、这样配置之后,重新启动该软件,重复2中的连接配置,测试连接,这时就连接成功了。成功之后就可以看到”TEST”用户的表了,可以很方便的操作数据库了,我这里还没创建表。

Navicat for Oracle工具连接oracle的方法教程

可右键 ‘表’ 导入、导出表,导入数据文件到新表中,让GISER人惊喜的是,ArcGIS的SHP数据集的dbf竟然也支持。

Navicat for Oracle工具连接oracle的方法教程

我所使用的数据库是oracle11g,我们下载的是Instant client这个工具,它有11的和10的版本,对oracle9i及以上的版本使用11的。其他使用10版本的。

以上就是Navicat for Oracle工具连接oracle的方法步骤(图文)的详细内容,更多请关注学派吧其它相关文章!

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/web/2154.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
Navicat查看MySQL日志的教程-学派吧
上一篇 2018年11月26日 下午9:59
MySQL用Navicat导出数据字典的方法-navicat教程
下一篇 2018年11月26日 下午9:59

相关推荐

  • 景安快云vps服务器搭建如何搭建WordPress

    现在有很多朋友想自己做个博客、或者一个展示页面,如今要实现自己的博客网站已经很简单了。这几天我就尝试了一下,随便记录下来,给网友分享下做自己的博客是需要一些东西的 1:域名:国内一些大型的网络公司的都可以的 阿里云、腾讯云 景安云、西部云、 2 :服务器:现在服务器太多了。五花八门、很多人都不知道如何下手、小编今天给大家简单介绍下、阿里、腾讯、大公司、适合会…

    2018年9月4日
    5.1K00
  • 帝国CMS-导入网站后,无法生成不了新闻解决方法

    帮客户迁移一个网站(LINUX+APACHE+MYSQL)帝国CMS,网站后台可以登陆,原网站内容和新闻可以访问,但修改和新增后,生成不了新的HTML  新HTML打开提示404, 1.查看MYSQL数据表,新闻里表里已经有这个一条记录, 2.查看服务器网站目录,新闻目录下没有生成HTML 解决办法 如果是liunx系统,需要给这个目录777属性,不然文章生…

    建站问题 2018年10月20日
    5.0K00
  • 使用SMTP插件解决WordPress注册邮件无法发送的问题教程

    不少用户提到自己的主机无法正常发送注册邮件,引起的原因有很多,而大部分原因是由于主机禁用了mail函数 111 面对以上问题,使用独立服务器的用户毫不担心,因为可以去开启mail函数,这点就不用在这给出解决方案了;还有一部分用户没有独立的云服务器,没有改动服务器环境的权限,这就需要绕一圈来解决这个问题,其实说绕一圈不如说这是更好的解决方案:使用SMTP插件来…

    建站问题 2018年10月24日
    4.6K00
  • 又一次rm -rf /*造成的惨剧! 学派吧

    据云头条报道,VPS 服务商 Kuriko 因 rm -rf /*,宿主机上所有数据丢失了。 Kuriko 4 月 24 日在其官网刊登香港 NAT 区故障声明,内容如下:由于机房技术的rm -rf /*,导致目前宿主机上所有数据丢失,我们正在尝试恢复原有数据以及获取备份资料,但恢复可能较小。目前该区域所有主机处于 OFFLINE 中。 rm 是 linux…

    建站问题 2018年10月17日
    3.8K00
  • WordPress上传图片提示http错误及解决方法

    学派吧-今天小编看到群里的兄弟说 他的wordpress无法上传图片。看到后。我看了下资料。并发给了他解决方法。等待测试结果。 报错: 网上的方法千篇一律,要么修改服务器设置,要么改.htaccess文件,而今天为大家提供一种更实用的方法,利用wp的过滤器来修复此http错误。将下面的代码添加到主题的functions.php文件中即可。 add_filte…

    2018年9月19日
    3.9K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部