apache如何做到日志分割-Linux运维-学派吧

现在许多网站都是用 apache 做 web 代理的,随时间时间的推长,apache 的访问日志 access.log 会越来越大,所以如果能实现每天分割成一个新得日志,这是比较方便管理的。

当然,apache 本身就具备这样的功能,我需要在 apache 的配置文件中,每个网站的日志部分需要调整成如下的格式

httpd.conf:ErrorLog "| /usr/local/apache/bin/rotatelogs /data/www/log/%Y_%m_%d_error.log 86400 480"
httpd.conf: CustomLog "| /usr/local/apache/bin/rotatelogs /data/www/log/%Y_%m_%d_access.log 86400 480" common

在上面的 ErrorLog 和 CustomLog 需要调整成上面的格式。

最后的效果如下

apache如何做到日志分割-Linux运维-学派吧

如果有不懂的、欢迎加入我们学派吧。一起学习交流。

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/612.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
上一篇 2018年9月30日 下午2:01
MySQL 5.7并发复制和mysqldump相互阻塞引起的复制延迟-Linux运维日志
下一篇 2018年9月30日 下午7:29

相关推荐

  • 如何处理Ping ECS实例的IP地址间歇性丢包-linux教程

    本篇文章给大家带来的内容是关于如何处理Ping ECS实例的IP地址间歇性丢包,有一定的参考价值,有需要的朋友可以参考一下,希望对你有所帮助。 Ping ECS实例的IP地址间歇性丢包 问题描述 Ping ECS实例的IP地址间歇性丢包,ECS实例的网络一直处于不稳定状态 。 问题原因 系统中病毒。 解决方案 Ping外部存在丢包,但是延迟不大,排查不是带宽…

    服务器运维 2018年11月21日
    2.9K00
  • IIS7.0在win2008下的安装配置教程(图文)-win运维-学派吧

    这篇文章主要为大家详细介绍了windows2008下IIS 7.0安装配置教程的相关资料,需要的朋友可以参考下 在windows2008下安装IIS 7.0,一共7个步骤。 步骤 启动服务器管理器点击开始菜单->所有程序->管理工具->服务器管理器,启动服务器管理器,界面如下: 增加一个服务器角色 在服务器管理器中,选择角色,你将可以看到角…

    服务器运维 2018年12月2日
    3.3K00
  • 宝塔腾讯云php无法启动的N种常见错误解决教程

    情况一:sock已经被监听 解决方法:将这个路径下的文件删除后再重启 /tmp/php-cgi-56.sock进入ssh 执行以下命令再重启php 具体不同的php版本,需要将以上命令的56更换为具体报错的php版本号,不能生搬硬套哦 情况二: libonig.so.2问题 解决方法:进入ssh 执行这条命令 再尝试启动 情况三: fatal error u…

    2024年10月17日
    2.2K00
  • linux中gerp有什么用及使用教程详解

    Linux系统中grep命令是一种强大的文本搜索工具,它能使用正则表达式搜索文本,并把匹配的行打印出来。 Linux grep命令 Linux grep命令用于查找文件里符合条件的字符串;也可以用于查找内容包含指定的范本样式的文件。它能使用正则表达式搜索,用于在文件中搜索指定的字符串模式,列出含有匹配模式子符串的文件名,并输出含有该字符串的文本行。 grep…

    2019年3月13日
    3.4K00
  • linux system intstall VGA driver解决方法

    1.AMD $ sudo apt-get install  fglrx 2.Nvidia $ sudo apt-get install nvidia-current —————–installed after———– restart you…

    服务器运维 2019年1月15日
    2.9K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部