Linux-centos下nginx日志每天定时切割教程

Linux-centos下nginx日志每天定时切割教程

教程目的:

使用Linux系统自带的命令logrotate对Nginx日志进行切割。

Nginx安装目录:/usr/local/nginx/

Nginx日志目录:/usr/local/nginx/logs/、/usr/local/nginx/logs/nginx_logs/

1、添加nginx日志切割脚本

cd  /etc/logrotate.d  #进入目录

vi   /etc/logrotate.d/nginx   #编辑脚本

/usr/local/nginx/logs/*.log  /usr/local/nginx/logs/nginx_logs/*.log{

missingok

dateext

notifempty

daily

rotate 7

sharedscripts

postrotate

if [ -f /usr/local/nginx/logs/nginx.pid ]; then

kill -USR1 `cat /usr/local/nginx/logs/nginx.pid`

fi

endscript

}

:wq!  #保存退出

chmod +x  /etc/logrotate.d/nginx  #添加执行权限

2、执行脚本

/usr/sbin/logrotate -vf  /etc/logrotate.d/nginx

3、添加定时任务

crontab  -e  #添加以下代码

0 0 * * * /usr/sbin/logrotate -vf /etc/logrotate.d/nginx  #每天凌晨定时执行脚本

至此,Linux下nginx日志每天定时切割教程完成。

备注:logrotate相关参数说明

missingok:忽略错误,如“日志文件无法找到”的错误提示。

dateext:切换后的日志文件会附加上一个短横线和YYYYMMDD格式的日期,没有这个配置项会附加一个小数点加一个数字序号

notifempty:如果日志文件为空,不执行切割。

daily:按天切割日志。可用值月:monthly 周:weekly 年:yearly

rotate 7:保留最近7天的日志记录

sharedscripts:只为整个日志组运行一次的脚本

postrotate和endscript:里面指定的命令将被执行。

compress::在轮循任务完成后,已轮循的归档将使用gzip进行压缩。

delaycompress::总是与compress选项一起用,delaycompress选项指示logrotate不要将最近的归档压缩,压缩将在下一次轮循周期进行。这在你或任何软件仍然需要读取最新归档时很有用。

create 644 root root: 以指定的权限创建全新的日志文件,同时logrotate也会重命名原始日志文件。

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/1321.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
win2003服务器远程桌面登录出现“终端服务器超出了最大允许连接数”解决教程 |
上一篇 2018年10月17日 下午10:35
SQL Server 2000安全设置之-数据库危险存储过程的删除与恢复系教程
下一篇 2018年10月17日 下午10:36

相关推荐

  • 学派吧-linux中xargs命令技巧的各种使用详解-linux教程

    xargs是给命令传递参数的一个过滤器,也是组合多个命令的一个工具。下面这篇文章主要给大家介绍了关于linux中xargs命令用法的相关资料,需要的朋友可以参考借鉴,下面来跟着小编一起看看吧。 前言 xargs命令是把接收到的数据重新格式化,再将其作为参数提供给其他命令,下面介绍xargs命令的各种使用技巧,一起来看看吧。 一、将多行输入转换成单行输入: […

    服务器运维 2018年12月19日
    2.2K00
  • nginx配置location教程及rewrite规则教程

    nginx配置location教程及rewrite规则教程 location正则写法 实际使用建议 Rewrite规则 flag标志位 if指令与全局变量 if判断指令 全局变量 常用正则 rewrite实例 location正则写法 一个示例: location = / { # 精确匹配 / ,主机名后面不能带任何字符串 [ configuration A…

    服务器运维 2018年10月11日
    2.0K00
  • linux/centos中删除文件命令是什么:警告请勿乱用-学派吧

    在Linux系统中我们可以通过rm-rf命令来删除文件,-r表示的是向下递归不管有多少级一并删除,-f表示直接强行删除并且不作任何提示。 在linux系统中删除目录很简单,我们可以使用rmdir命令来删除,但是当目录为非空时就会遇到麻烦。现在我们可以直接使用rm -rf命令来删除即可 【推荐课程:Linux教程】 语法: rm -rf 目录名字 参数详解: …

    服务器运维 2019年5月7日
    3.7K00
  • Linux实例负载高问题排查和异常处理

    问题描述 在您使用ECS实例过程中,可能会遇到实例系统负载较高的情况,负载过高,可能会引发一系列异常问题,简单说明如下: CPU使用率或负载过高:一般来说,当CPU使用率≥80%时,定义为CPU使用率过高。CPU使用率持续过高,可能会导致实例运行速度变慢,自动关机或重启、无法登录等问题。 带宽使用率过高:一般来说,带宽使用率≥当前带宽80%时,定义为带宽使用…

    2024年9月28日
    2.0K00
  • python升级带来的yum异常问题:File “/usr/bin/yum”, line 30

    今天给大家带来一个关于python的问题。 问题: $ yum File “/usr/bin/yum”, line 30 except KeyboardInterrupt, e: ^ SyntaxError: invalid syntax 原因: 这是因为yum采用python作为命令解释器,这可以从/usr/bin/yum文件中第一…

    服务器运维 2019年7月23日
    3.9K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部