centos (linux)下无法删除文件的原因,提示:不允许的操作

centos下 无法对文件进行编辑删除,等原因的解决方法

使用rm删除文件和文件夹的时候提示:rm: 无法删除”bash”: 不允许的操作

解决方法:

1、查看文件属性

1
lsattr filetodel<br>----ia-------e- filetodel

可以看到此文件有-i 和-a属性,此时我们只要将此属性删除掉即可

通过命令 chattr,可以设置文件/文件夹的隐藏属性,来保证文件/文件夹的安全.其中比较重要的参数为i和a.这两个属性只有root用户才可以设置或清除.而通过命令 lsattr 可以查看这些属性.

2、删除属性:

1
2
3
chattr -i authorized_keys2
chattr -a authorized_keys2
chattr -u authorized_keys2

再次删除该文件,即可正常删除了

 

主题测试文章,只做测试使用。发布者:云大使,转转请注明出处:https://www.xp8.net/server/3920.html

赞 (0)
打赏 微信扫一扫 微信扫一扫
centos_linux分区格式化大于2 TiB数据盘 腾讯云代理测试
上一篇 2020年4月7日 下午8:23
Linux-centos下GPT格式磁盘重新格式化为MBR格式
下一篇 2020年7月28日 下午2:05

相关推荐

  • 如何在Docker容器里创建Apache Web服务-Linux运维-学派吧

    有需要服务器方面的需求和咨询,可以联系博主QQ 7271895(收费) 1. CentOS 和 Ubuntu安装 Docker 2. 创建Apache容器 作为Linux系统管理员,或多或少都有可能听说过Docker。因为这款软件可以有效降低运营成本,提升系统部署速度,让系统管理工作变得十分轻松。 但这一切也不是变魔术,Docker只是一个容器管理平台,可以…

    2018年9月30日
    2.3K00
  • Apache禁止访问目录-Linux运维日志

    欢迎来到学派吧-如有需要服务器等业务相关资讯的加我们QQ群 设置Apache禁止访问目录 本文将详细介绍如何操作禁止显示apache网站根目录 进入apache的配置文件 httpd.conf 找到: vim /etc/httpd/conf/httpd.conf Options Indexes FollowSymLinks 修改为: Options Foll…

    服务器运维 2018年9月30日
    2.4K00
  • 关于使用宝塔面板打不开问题

    宝塔的liunx面板确实是我用过的至今为止最好的面板,简化很多操作,不过在使用做也会遇到一些坑,有时候会出现打不开的情况。宝塔各种命令操作 https://www.bt.cn/btcode.html 1、重启服务器后面板打不开,网站不能访问,这个问题一般是掉盘引起的,解决方法是一般是用下面的命令修复下 wget -O update.sh http://dow…

    服务器运维 2018年8月3日
    12.5K00
  • 宝塔apache无法启动:httpd: Syntax error on line 501 of

    今天宝塔突然apache启动不了.网站打不开。提示: 报错:Apache配置规则错误:[url=]httpd: Syntax error on line 501 of /www/server/apache/conf/httpd.conf: Syntax error on line 1 of /www/server/panel/vhost/apache/btw…

    2018年10月8日
    9.7K00
  • Linux下nginx安装教程的图文教程讲解-学派把

    如果您有服务器咨询问题、购买问题、可以联系我们客服 7271895 690624商祺云-阿里代理、景安代理、西部代理 这篇文章主要为大家详细介绍了Linux中Nginx的安装教程,具有一定的参考价值,感兴趣的小伙伴们可以参考一下 Linux下Nginx安装教程分享,具体内容如下 1、安装编译文件及库文件 yum -y install make zlib zl…

    2019年1月4日
    2.5K00

发表回复

登录后才能评论
联系我们

联系我们

18838889666

在线咨询: QQ交谈

邮件:xinyun@88.com

工作时间:周一至周五,9:30-18:30,节假日休息

添加微信
添加微信
分享本页
返回顶部